Castle Clash - iOS Today: 0    Total Posts: 774


Create Thread

[Bug & Suggestion] Problem log into cc

[Copy link] 2/769

Posted on 7/27/17 4:34:08 AM | Show thread starter's posts only

I can't log into castle clash after the update today. I tried to delete the game and reinstall, but the problem remains. What should I do?

Posted on 7/27/17 5:01:33 AM | Show thread starter's posts only

Unfortunately, reinstalling the game would be my offered solution to any unusual bug occurring due to the update.  As of this post, the update has only been released an hour, and the game is buggy.  From my own personal experience playing for over 3 years, it is not unheard of for issues to resolve themselves, once the update has been live for a few hours. 

For now, please post your bug in the Version 1.8.3 bug thread for the Developers to see.

iOS - DarkKnights
Posted on 7/27/17 5:19:40 AM | Show thread starter's posts only

I am having the same problem. The game was fine up until the update. Now I see the main loading screen for maybe 1-2 seconds and it crashes. Tried a reinstall, device reboot, and still no use.

f2p and flying!
Join Mutilator!!!